Replika

ChatBot/LifeBox/CoachBot

https://replika.ai/

Installing OpenSource CakeChat

https://github.com/lukalabs/cakechat

Mar01'2018

  • create new virtualenv which gives me Python 2.7.10 (default, Feb 7 2017, 00:08:15)
  • download requirements.txt and run pip
    • dies with SSL: TLSV1_ALERT_PROTOCOL_VERSION omg OpenSSL again.
    • this suggests Python 2.7.14 won't have the issue
    • so remove the whole envir, then try virtualenv replika --python=python2.7.14 but that says executable doesn't exist
    • see "Python is at 2.7.13" at OpenSSL, do upgrade again?
    • brew update && brew upgrade python gives Error: Xcode alone is not sufficient on Sierra.
    • try xcode-select --install
    • again brew update && brew upgrade python now get Already up-to-date. Which is what I got at some point over at OpenSSL page. So run that long script again, but stop it when it prompts me to delete something that I'm afraid will screw something else up.
    • re-create virtualenv, activate, openssl version now gives OpenSSL 1.0.2l 25 May 2017
    • run pip again get the original TLSV1_ALERT_PROTOCOL_VERSION error again
    • do python -c "import ssl; print(ssl.OPENSSL_VERSION)" I get the old OpenSSL 0.9.8zh 14 Jan 2016
    • do brew upgrade openssl, then the 2 export...path lines. Start new Terminal, etc. Try pip fail again.
    • recheck with python -c 'import ssl; print(ssl.OPENSSL_VERSION)' which gives me OpenSSL 0.9.8zh 14 Jan 2016 still grrr

Mar02

  • Realized last link I used said to deactivate all virtualenvs running. Which I hadn't done. So repeat that brew update/upgrade plus the rest of the steps
    • argh python -c 'import ssl; print(ssl.OPENSSL_VERSION)' still gives OpenSSL 0.9.8zh 14 Jan 2016
    • just in case, try pip... anyway, nope still original failure

Mar03

  • Decide to pop up a level and install latest Mac Python 2.7.14 which supposedly includes recent OpenSSL.
    • Python 2.7.14 (v2.7.14:84471935ed, Sep 16 2017, 12:01:12)
    • but python -c 'import ssl; print(ssl.OPENSSL_VERSION)' -> OpenSSL 0.9.8zh 14 Jan 2016 just shoot me
  • restart whole machine
  • rebuild virtualenv -p /Library/Frameworks/Python.framework/Versions/2.7/bin/python replika
  • bah still old OpenSSL

Mar04

  • weirdness
    • hmm seems like none of my virtualenv-s respond with the right OpenSSL version
    • also notice my TwitterBots haven't been running
    • launch the virtualenv that holds them; it responds with old OpenSSL. But I run a tweet anyway, and it works. And tweets again by itself a few minutes later. So that virtualenv seems ok.
  • oblique-attack - Replika uses Flask as a web UI, and I have a virtualenv for Flask already, so I'm just going to add this stuff into that one.
    • nope same TLSV1 error

It is possible issue is related to GitHub recent change Weak cryptographic standards removed?


Edited: |

blog comments powered by Disqus